When troubleshooting FlexLM licensing issues on an end user machine, the first step is to always ensure that the correct product and version license is available on the server. Do not assume that just because it worked yesterday, it still does, as your IT department may have had something to say about it!
There is a known compatibility issue with the current Ideate vendor daemon where in many instances LMTools 11.19.9 is unable to recognize that the service is started correctly and licenses are available. The error is ‘Server start failed’. The ‘Perform Status Inquiry’ will also incorrectly return a ‘No socket connection’ error. The service log will report the status correctly, it will also record the license check-outs and check-ins as expected. The network licenses continue to function as expected.
The license service log will display the correct status, including the records of Check OUT and Check IN when licenses are being used.
An example of a correct server log state:

View only state may be caused by all licenses taken up by other users. See the section “Check License availability” above before troubleshooting further.
These are especially common when using a VPN or cross-domain server access. Please test accessing the license by using @serverIP or @fully qualified domain name to help your DNS to route the request correctly.
Depending upon the network speed, a request for a license may time out before the request reaches the license server. In this event the software will display an error ‘Service may be down or unavailable’ and may lapse into View-Only Mode. This can be quite common for remote or VPN users. This issue can be fixed by creating an environment variable on the workstation. The system variable should be named FLEXLM_TIMEOUT and a recommended setting would be 1000000.

The most common reasons why a licensing service does not start or shows errors when you review the service log:
If licenses show as available, but you can’t access them from the user workstation, do not proceed with the steps below, go here instead!
If the issue is not resolved, contact Ideate Technical Support ([email protected]).
If, after setting up the Ideate FlexLM license service, the network licenses for Autodesk (or any other vendor) stop working, follow these steps in LMTools. If the issue is not resolved, contact Graitec Technical Support.
There are a few common licensing errors that can occur. This list explains the error and the first steps to resolving it.
-4 Licensed number of users already reached. Wait for licenses to be available. You can determine who is using licenses by performing a Status Enquiry on the server(s). Refer to Verify Service is Running.
-5 No such feature exists. Verify that you have licenses for the software you are trying to use. Either install the correct software title or request a new license file.
-10 Feature has expired. Request a new license file.
-15 Cannot connect to license server system. This is a general connectivity error.

-18 License server system does not support this feature. Verify that you have licenses for the software you are using. Not all Ideate Apps are part of IdeateApps!
-96 License server machine is down or not responding. Check if the license service is running, then check your server Windows Firewall rules. See more here. If the error still occurs, identify which workstations and which software is affected and contact Ideate Technical Support.
-97 The desired vendor daemon is down. Restart the license service. If the error still occurs, identify which workstations and which software is affected and contact Ideate Technical Support.
-124 License Return Error – This can occur in both Revit and the Ideate software when the licenses are not returned in the order they were borrowed. This is a known Flexera issue. Read more about this under the License Borrowing topic in this document.